v0.98.1 (2017-12-04)

v0.98.1 is a patch release that fixes a couple of minor bugs. The primary change in this release, however, is that the 'visidata' package on PyPI no longer includes all of the loaders' dependencies by default.

This is a minor hassle for first-time users if they want to use certain formats, but since the goal is eventually supporting every possible data format, installing all dependencies for all users by default is not tenable. The base VisiData already includes support for tsv, csv, fixed width, sqlite, graphs and more. Most users will only need one or two additional dependencies.

To install VisiData with all dependencies for all loaders:

pip3 install "visidata[full]"

Of course, you can install just the dependencies you need. See "SUPPORTED SOURCES" in the manpage for which packages to install.